package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+(?:,\d+)?[[:alpha:]]*)`)
var str = `4,05g`
var substitution = "{\1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}