$re = '/(\d+(?:,\d+)?[[:alpha:]]*)/m';
$str = '4,05g';
$subst = "{\1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;