$re = '/^[^\S\r\n]*(.*\bMISSILE \d.*(?:\r?\n(?!.*\b(?:MISSILE|A\/C) \d).*)*\r?\n[ ]+A\/C[ ]+[0-9]{1,2}[ ]+IS[ ]+KILLED[ ]+AT[ ]+TIME[ ]+[0-9]{0,4}\.[0-9]{0,4})/m';
$str = ' MISSILE 010102 FUZES AGAINST 2 RNG= 0.0 T= 82.846
TERMINAL POSITION: X= -75933.67 Y= -4469.98 Z= 25000.09
LAUNCH POSITION: X= -127017.19 Y= -12934.89 Z= 25506.47 MODE CMD_GUIDED_DES_RDR
AVERAGE VELOCITY= 3375.35
TERMINAL VELOCITY= 2545.36
LAUNCHER POSITION: X= -113879.58 Y= -16624.14 Z= 24476.13
FPOLE= 39848.34
GUIDANCE TRACKBANK 1 HAS TRACK ON FUZEE SEEKERS CONTRIBUTING INFRA-RED
ENDGAME SEEKER: IR 1
A/C 2 IS KILLED AT TIME 82.907
MISSILE 010102 FUZES AGAINST 3 RNG= 0.0 T= 82.846
TERMINAL POSITION: X= -75933.67 Y= -4469.98 Z= 25000.09
LAUNCH POSITION: X= -127017.19 Y= -12934.89 Z= 25506.47 MODE CMD_GUIDED_DES_RDR
AVERAGE VELOCITY= 3375.35
TERMINAL VELOCITY= 2545.36
LAUNCHER POSITION: X= -113879.58 Y= -16624.14 Z= 24476.13
FPOLE= 39848.34
GUIDANCE TRACKBANK 1 HAS TRACK ON FUZEE SEEKERS CONTRIBUTING INFRA-RED
ENDGAME SEEKER: IR 1
A/C 3 IS KILLED AT TIME 82.907';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);