import re
regex = re.compile(r"^-?(\d|[1-9]+\d*|\.\d+|0\.\d+|[1-9]+\d*\.\d+)$", flags=re.MULTILINE)
test_str = ("0\n"
"5\n"
"50\n"
".5\n"
".05\n"
"5.5\n"
"5.05\n"
"5.050\n"
"5.50\n"
"0.5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")