re = /^-?(\d|[1-9]+\d*|\.\d+|0\.\d+|[1-9]+\d*\.\d+)$/m
str = '0
5
50
.5
.05
5.5
5.05
5.050
5.50
0.5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end