use strict;
my $str = '13371337:Bat,TH,Li-Met,Blub,9.5V,370mAHr,1/2_AA-Cell,50pcs,13351234:Radio - Antenna 2.4 GHz AB/C midi (10p),15642345:Board SMB - Some Magic Board,95653345:Board SMK 6 - Some Magic Knobs - Mod6,56735632:Control Unit Z65 - Mod9';
my $regex = qr/(?<!^)\b[0-9]{5,9}:/mp;
my $subst = '\\n\\g<0>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";