#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)^([\p{L}\p{N}\. ]+)(, ?| )([0-9-]+[a-z]?)(, ?| |$)(.*)"
Local $sString = "Valid examples:" & @CRLF & _
"" & @CRLF & _
"Text Text 123 anything" & @CRLF & _
"Text Text, 123, anything" & @CRLF & _
"Text Text 123B anything" & @CRLF & _
"Text Text, 123B, anything" & @CRLF & _
"Text 123 anything" & @CRLF & _
"Text 123B anything" & @CRLF & _
"Text, 123, anything" & @CRLF & _
"Text, 123B, anything" & @CRLF & _
"987 123 anything" & @CRLF & _
"987 123B anything" & @CRLF & _
"987, 123, anything" & @CRLF & _
"987, 123B, anything" & @CRLF & _
"" & @CRLF & _
"(Need to be) Invalid examples:" & @CRLF & _
"" & @CRLF & _
"Text Text 456 123 anything" & @CRLF & _
"Text Text, 456, 123, anything" & @CRLF & _
"Text Text 456 123B anything" & @CRLF & _
"Text Text, 456, 123B, anything" & @CRLF & _
"Text 456 123 anything" & @CRLF & _
"Text 456 123B anything" & @CRLF & _
"Text, 456, 123, anything" & @CRLF & _
"Text, 456, 123B, anything" & @CRLF & _
"987 456 123 anything" & @CRLF & _
"987 456 123B anything" & @CRLF & _
"987, 456, 123, anything" & @CRLF & _
"987, 456, 123B, anything" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")