import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\p{L}\\p{N}\\. ]+)(, ?| )([0-9-]+[a-z]?)(, ?| |$)(.*)";
final String string = "Valid examples:\n\n"
+ "Text Text 123 anything\n"
+ "Text Text, 123, anything\n"
+ "Text Text 123B anything\n"
+ "Text Text, 123B, anything\n"
+ "Text 123 anything\n"
+ "Text 123B anything\n"
+ "Text, 123, anything\n"
+ "Text, 123B, anything\n"
+ "987 123 anything\n"
+ "987 123B anything\n"
+ "987, 123, anything\n"
+ "987, 123B, anything\n\n"
+ "(Need to be) Invalid examples:\n\n"
+ "Text Text 456 123 anything\n"
+ "Text Text, 456, 123, anything\n"
+ "Text Text 456 123B anything\n"
+ "Text Text, 456, 123B, anything\n"
+ "Text 456 123 anything\n"
+ "Text 456 123B anything\n"
+ "Text, 456, 123, anything\n"
+ "Text, 456, 123B, anything\n"
+ "987 456 123 anything\n"
+ "987 456 123B anything\n"
+ "987, 456, 123, anything\n"
+ "987, 456, 123B, anything\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}