$re = '/<entry key="(?!SvsAdapter\b).*/m';
$str = '<entry key="SvsAdapter" value-ref="svsAdapter"/>
<entry key="AdyenAdapter" value-ref="adyenAdapter" />
<entry key="PaymentExpressAdapter" value-ref="paymentExpressAdapter"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);