re = /<entry key="(?!SvsAdapter\b).*/m
str = '<entry key="SvsAdapter" value-ref="svsAdapter"/>
<entry key="AdyenAdapter" value-ref="adyenAdapter" />
<entry key="PaymentExpressAdapter" value-ref="paymentExpressAdapter"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end