re = /([0-9,]+)/m
str = 'See all 200 employees
See all 2,000 employees
See all 2,000,000 employees'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end