import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1\\d{10}$|^(\\d{3,4}[-\\/]?)?\\d{7,8}([-\\/]\\d{2,4})?$";
final String string = "1234567\n"
+ "12345678\n"
+ "01212345678\n"
+ "012-12345678\n"
+ "1234-1234567\n"
+ "1234-12345678\n"
+ "012/1234567\n"
+ "012/12345678\n"
+ "1234/1234567\n"
+ "1234/12345678\n"
+ "13585881145\n"
+ "012-1345678-1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}