// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^1\d{10}$|^(\d{3,4}[-\/]?)?\d{7,8}([-\/]\d{2,4})?$").unwrap();
let string = "1234567
12345678
01212345678
012-12345678
1234-1234567
1234-12345678
012/1234567
012/12345678
1234/1234567
1234/12345678
13585881145
012-1345678-1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}