using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9-_\.]+$";
string input = @"gabo8-08_2017.com
gabo2k8@08_2017.com
gabo2k808#
gabo2k8-08_2017.com
gabo2k808
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}