$re = '/^[a-zA-Z0-9-_\.]+$/m';
$str = 'gabo8-08_2017.com
gabo2k8@08_2017.com
gabo2k808#
gabo2k8-08_2017.com
gabo2k808
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);