#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\"(.*)\"|\s([A-Z_].*)"
Local $sString = "AddAgenda("Gangster's agenda", " & @CRLF & _
"{ " & @CRLF & _
" TEAM_HITMAN, " & @CRLF & _
" TEAM_POLICE" & @CRLF & _
"}, " & @CRLF & _
"{ " & @CRLF & _
" TEAM_GANG," & @CRLF & _
" TEAM_MAFIA," & @CRLF & _
" TEAM_GANGSTER" & @CRLF & _
"})"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")