package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"(.*)\"|\s([A-Z_].*)`)
var str = `AddAgenda("Gangster's agenda",
{
TEAM_HITMAN,
TEAM_POLICE
},
{
TEAM_GANG,
TEAM_MAFIA,
TEAM_GANGSTER
})`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}