$re = '/^(?!À-Ö)[A-Za-z0-9\',\-àâçèéêîôùû ]*$/';
$str = 'àâçèéêîôùû';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);