package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\p{L}[\p{L}\p{Mark}\p{Decimal_Number}\p{Connector_Punctuation} -]*$`)
var str = `example
example
example3
example3
example3- `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}