re = /^\p{L}[\p{L}\p{Mark}\p{Decimal_Number}\p{Connector_Punctuation} -]*$/mi
str = 'example
example
example3
example3
example3- '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end