use strict;
my $str = '101.23052.0004';
my $regex = qr/([6]\.[1]\.([3-9]$|[1-9]\d{1,}))|([6]\.([2-9]|[1-9]\d{1,})\.\d*)|(([7-9]|[1-9]\d{1,})\.\d*\.\d*)/mp;
my $subst = '101.23052.0004';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";