$re = '/(do you) (?!lie\b)[a-zA-Z]{3,}/m';
$str = 'do you a
do you lie
do you lied';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);