re = /\[[Pp]rivate\](?=\S)/m
str = '[Private]
[private]
[Private]this is a test
not these right?
[Private] this is a test
[Private]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end