using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\w;)+\w\n)(-{3,}\n)((\w;)+\w\n)+";
string input = @"H;e;l;a;a
---------
J;a;c;k;p
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}