use strict;
my $str = 'package {
import flash.display.Sprite;
/*
^([ \\f\\t]*)([^\\/\\n]*)\\.text\\s*=[ \\f\\t]*([^$;\\n=]+)
$1UIUtils.updateLabel($2, $3)
*/
public class Test_RegexpReplace2 extends Sprite {
public function Test_RegexpReplace2() {
//valid
ttt.text = Localisation(STR_CODE);
ttt.text= Localisation(STR_CODE);
ttt.text= Localisation(STR_CODE);
ttt.text = Localisation(STR_CODE)
ttt.text=Localisation(STR_CODE);
tt.hghgt.text=Localisation(STR_CODE);
//invalid
preFilled.setVisible(field.text == "");
ttt.textLocalisation(STR_CODE);
ttt.text Localisation(STR_CODE);
ttttext=Localisation(STR_CODE)
tt.hghgt.text=;
tt.hghgt.text=
//_captionField.text = cover.caption;
/* _captionField.text = cover.caption;*/
this.text = text;
}
}
}
';
my $regex = qr/^([ \f\t]*)((?!this)[^\/\n])*\.text\s*=[ \f\t]*([^$;\n=]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}