import Foundation
let pattern = #"^([ \f\t]*)((?!this)[^\/\n])*\.text\s*=[ \f\t]*([^$;\n=]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
package {
import flash.display.Sprite;
/*
^([ \f\t]*)([^\/\n]*)\.text\s*=[ \f\t]*([^$;\n=]+)
$1UIUtils.updateLabel($2, $3)
*/
public class Test_RegexpReplace2 extends Sprite {
public function Test_RegexpReplace2() {
//valid
ttt.text = Localisation(STR_CODE);
ttt.text= Localisation(STR_CODE);
ttt.text= Localisation(STR_CODE);
ttt.text = Localisation(STR_CODE)
ttt.text=Localisation(STR_CODE);
tt.hghgt.text=Localisation(STR_CODE);
//invalid
preFilled.setVisible(field.text == "");
ttt.textLocalisation(STR_CODE);
ttt.text Localisation(STR_CODE);
ttttext=Localisation(STR_CODE)
tt.hghgt.text=;
tt.hghgt.text=
//_captionField.text = cover.caption;
/* _captionField.text = cover.caption;*/
this.text = text;
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)