import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:\\.\\d{0,2})?(?:,\\s*\\d+(?:\\.\\d{0,2})?)*,?$";
final String string = "1.23\n"
+ "1\n"
+ "1,\n"
+ "1.2,4\n"
+ "1.23, 4\n"
+ "1.23, 4,\n"
+ "1, 2.34\n"
+ "1.\n"
+ "1,,\n"
+ "1.234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}