const regex = /^\d+(?:\.\d{0,2})?(?:,\s*\d+(?:\.\d{0,2})?)*,?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(?:\\.\\d{0,2})?(?:,\\s*\\d+(?:\\.\\d{0,2})?)*,?$', 'gm')
const str = `1.23
1
1,
1.2,4
1.23, 4
1.23, 4,
1, 2.34
1.
1,,
1.234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}