package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d*[0-9](|.\d*[0-9]|)*$`)
var str = `1111111111111111111111111!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}