$re = '/^\d*[0-9](|.\d*[0-9]|)*$/';
$str = '1111111111111111111111111!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);