import Foundation
let pattern = #"(?(DEFINE)(?'Row'(?:<\/td)?>[^>]+>))^ +<tr class="clickable" data-id="(?<AccountID>[^"]+)" data-jobid=\"(?<JobID>[^\"]+)\"(?P>Row)(?<InvoiceID>[^<]+)(?P>Row)(?<Date>[^ ]+)\n +(?P>Row)(?<Status>[^<]+)(?P>Row)(?<Type>[^<]+)(?P>Row)(?<Total>[^<]+)(?P>Row)(?<Balance>[^<]+)(?P>Row)(?<Paid>[^<]+)(?P>Row)(?<Technician>[^<]+)(?P>Row)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<th>Technician</th>
<th></th>
</tr>
</thead>
<tbody>
<tr class="clickable" data-id="277928" data-jobid="3100878">
<td>3142140</td>
<td>07/21/2017
</td>
<td>Complete</td>
<td>Initial</td>
<td>$309.00</td>
<td>$316.76</td>
<td>No</td>
<td>John Smith</td>
<td>
<div class="btn-group pull-right">
<a class="btn btn-small dropdown-toggle" data-toggle="dropdown" href="javascript:;">Action <span class="caret"></span></a>
<ul class="dropdown-menu">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)