const regex = /<br>\s?-\s?(.*?)(?=<br>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<br>\\s?-\\s?(.*?)(?=<br>)', 'gm')
const str = `any text - any text any text any text any text any text
<br><br>- any text any text<br>- any text 1 2 3 | \\ ,<br><br>
<br>any text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}