$re = '/<br>\s?-\s?(.*?)(?=<br>)/m';
$str = 'any text - any text any text any text any text any text
<br><br>- any text any text<br>- any text 1 2 3 | \\ ,<br><br>
<br>any text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);