package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)['"]?(\w+)['"]?[ ]?:[ ]?{(.[^}]+)}`)
var str = `{
"Employer" : {
Name: 'Sample',
Age: 23
},
Employer: {
Name: 'Sample',
Age: 23
},
Employer: {
Name: 'Sample',
Age: 23
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}