using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{0,50}\S*";
string input = @"This paper proposes a method that allows non-parallel many-to-many voice conversion by using a variant of a generative adversarial network called StarGAN.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}