package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).{0,50}\S*`)
var str = `This paper proposes a method that allows non-parallel many-to-many voice conversion by using a variant of a generative adversarial network called StarGAN.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}