package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(%data:([^,.]+)[.,|\/](?:ROW)\[(\d+)\][.,|\/]([^.,]+)%)$`)
var str = `%data:ResultsetName,row[3].BlaBla%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}