re = /^(%data:([^,.]+)[.,|\/](?:ROW)\[(\d+)\][.,|\/]([^.,]+)%)$/i
str = '%data:ResultsetName,row[3].BlaBla%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end