import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sx)(\\p{Nd})\n"
+ "(?=.*:\\1=(\\w+)\\b)";
final String string = "0 zero \n"
+ "1 ichi \n"
+ "2 ni \n"
+ "3 san \n"
+ "4 shi \n"
+ "5 go\n"
+ "6 roku\n"
+ "7 shichi\n"
+ "8 hachi\n"
+ "9 kyuu\n"
+ "Dictionary:0=0:1=1:2=2:3=3:4=4:5=5:6=6:7=7:8=8:9=9";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}