#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\x{1F1E6}-\x{1F1FF}]{2}|๐ด[\x{E0041}-\x{E007A}]{4,5}\x{E007F}"
Local $sString = "" & @CRLF & _
" ๐ Chequered Flag" & @CRLF & _
" ๐ฉ Triangular Flag" & @CRLF & _
" ๐ Crossed Flags" & @CRLF & _
" ๐ด Black Flag" & @CRLF & _
" ๐ณ White Flag" & @CRLF & _
" ๐ณ๏ธโ๐ Rainbow Flag" & @CRLF & _
" ๐ดโโ ๏ธ Pirate Flag" & @CRLF & _
" ๐ฆ๐จ Flag: Ascension Island" & @CRLF & _
" ๐ฆ๐ฉ Flag: Andorra" & @CRLF & _
" ๐ฆ๐ช Flag: United Arab Emirates" & @CRLF & _
" ๐ฆ๐ซ Flag: Afghanistan" & @CRLF & _
" ๐ฆ๐ฌ Flag: Antigua & Barbuda" & @CRLF & _
" ๐ฆ๐ฎ Flag: Anguilla" & @CRLF & _
" ๐ฆ๐ฑ Flag: Albania" & @CRLF & _
" ๐ฆ๐ฒ Flag: Armenia" & @CRLF & _
" ๐ฆ๐ด Flag: Angola" & @CRLF & _
" ๐ฆ๐ถ Flag: Antarctica" & @CRLF & _
" ๐ฆ๐ท Flag: Argentina" & @CRLF & _
" ๐ฆ๐ธ Flag: American Samoa" & @CRLF & _
" ๐ฆ๐น Flag: Austria" & @CRLF & _
" ๐ฆ๐บ Flag: Australia" & @CRLF & _
" ๐ฆ๐ผ Flag: Aruba" & @CRLF & _
" ๐ฆ๐ฝ Flag: ร
land Islands" & @CRLF & _
" ๐ฆ๐ฟ Flag: Azerbaijan" & @CRLF & _
" ๐ง๐ฆ Flag: Bosnia & Herzegovina" & @CRLF & _
" ๐ง๐ง Flag: Barbados" & @CRLF & _
" ๐ง๐ฉ Flag: Bangladesh" & @CRLF & _
" ๐ง๐ช Flag: Belgium" & @CRLF & _
" ๐ง๐ซ Flag: Burkina Faso" & @CRLF & _
" ๐ง๐ฌ Flag: Bulgaria" & @CRLF & _
" ๐ง๐ญ Flag: Bahrain" & @CRLF & _
" ๐ง๐ฎ Flag: Burundi" & @CRLF & _
" ๐ง๐ฏ Flag: Benin" & @CRLF & _
" ๐ง๐ฑ Flag: St. Barthรฉlemy" & @CRLF & _
" ๐ง๐ฒ Flag: Bermuda" & @CRLF & _
" ๐ง๐ณ Flag: Brunei" & @CRLF & _
" ๐ง๐ด Flag: Bolivia" & @CRLF & _
" ๐ง๐ถ Flag: Caribbean Netherlands" & @CRLF & _
" ๐ง๐ท Flag: Brazil" & @CRLF & _
" ๐ง๐ธ Flag: Bahamas" & @CRLF & _
" ๐ง๐น Flag: Bhutan" & @CRLF & _
" ๐ง๐ป Flag: Bouvet Island" & @CRLF & _
" ๐ง๐ผ Flag: Botswana" & @CRLF & _
" ๐ง๐พ Flag: Belarus" & @CRLF & _
" ๐ง๐ฟ Flag: Belize" & @CRLF & _
" ๐จ๐ฆ Flag: Canada" & @CRLF & _
" ๐จ๐จ Flag: Cocos (Keeling) Islands" & @CRLF & _
" ๐จ๐ฉ Flag: Congo - Kinshasa" & @CRLF & _
" ๐จ๐ซ Flag: Central African Republic" & @CRLF & _
" ๐จ๐ฌ Flag: Congo - Brazzaville" & @CRLF & _
" ๐จ๐ญ Flag: Switzerland" & @CRLF & _
" ๐จ๐ฎ Flag: Cรดte dโIvoire" & @CRLF & _
" ๐จ๐ฐ Flag: Cook Islands" & @CRLF & _
" ๐จ๐ฑ Flag: Chile" & @CRLF & _
" ๐จ๐ฒ Flag: Cameroon" & @CRLF & _
" ๐จ๐ณ Flag: China" & @CRLF & _
" ๐จ๐ด Flag: Colombia" & @CRLF & _
" ๐จ๐ต Flag: Clipperton Island" & @CRLF & _
" ๐จ๐ท Flag: Costa Rica" & @CRLF & _
" ๐จ๐บ Flag: Cuba" & @CRLF & _
" ๐จ๐ป Flag: Cape Verde" & @CRLF & _
" ๐จ๐ผ Flag: Curaรงao" & @CRLF & _
" ๐จ๐ฝ Flag: Christmas Island" & @CRLF & _
" ๐จ๐พ Flag: Cyprus" & @CRLF & _
" ๐จ๐ฟ Flag: Czechia" & @CRLF & _
" ๐ฉ๐ช Flag: Germany" & @CRLF & _
" ๐ฉ๐ฌ Flag: Diego Garcia" & @CRLF & _
" ๐ฉ๐ฏ Flag: Djibouti" & @CRLF & _
" ๐ฉ๐ฐ Flag: Denmark" & @CRLF & _
" ๐ฉ๐ฒ Flag: Dominica" & @CRLF & _
" ๐ฉ๐ด Flag: Dominican Republic" & @CRLF & _
" ๐ฉ๐ฟ Flag: Algeria" & @CRLF & _
" ๐ช๐ฆ Flag: Ceuta & Melilla" & @CRLF & _
" ๐ช๐จ Flag: Ecuador" & @CRLF & _
" ๐ช๐ช Flag: Estonia" & @CRLF & _
" ๐ช๐ฌ Flag: Egypt" & @CRLF & _
" ๐ช๐ญ Flag: Western Sahara" & @CRLF & _
" ๐ช๐ท Flag: Eritrea" & @CRLF & _
" ๐ช๐ธ Flag: Spain" & @CRLF & _
" ๐ช๐น Flag: Ethiopia" & @CRLF & _
" ๐ช๐บ Flag: European Union" & @CRLF & _
" ๐ซ๐ฎ Flag: Finland" & @CRLF & _
" ๐ซ๐ฏ Flag: Fiji" & @CRLF & _
" ๐ซ๐ฐ Flag: Falkland Islands" & @CRLF & _
" ๐ซ๐ฒ Flag: Micronesia" & @CRLF & _
" ๐ซ๐ด Flag: Faroe Islands" & @CRLF & _
" ๐ซ๐ท Flag: France" & @CRLF & _
" ๐ฌ๐ฆ Flag: Gabon" & @CRLF & _
" ๐ฌ๐ง Flag: United Kingdom" & @CRLF & _
" ๐ฌ๐ฉ Flag: Grenada" & @CRLF & _
" ๐ฌ๐ช Flag: Georgia" & @CRLF & _
" ๐ฌ๐ซ Flag: French Guiana" & @CRLF & _
" ๐ฌ๐ฌ Flag: Guernsey" & @CRLF & _
" ๐ฌ๐ญ Flag: Ghana" & @CRLF & _
" ๐ฌ๐ฎ Flag: Gibraltar" & @CRLF & _
" ๐ฌ๐ฑ Flag: Greenland" & @CRLF & _
" ๐ฌ๐ฒ Flag: Gambia" & @CRLF & _
" ๐ฌ๐ณ Flag: Guinea" & @CRLF & _
" ๐ฌ๐ต Flag: Guadeloupe" & @CRLF & _
" ๐ฌ๐ถ Flag: Equatorial Guinea" & @CRLF & _
" ๐ฌ๐ท Flag: Greece" & @CRLF & _
" ๐ฌ๐ธ Flag: South Georgia & South Sandwich Islands" & @CRLF & _
" ๐ฌ๐น Flag: Guatemala" & @CRLF & _
" ๐ฌ๐บ Flag: Guam" & @CRLF & _
" ๐ฌ๐ผ Flag: Guinea-Bissau" & @CRLF & _
" ๐ฌ๐พ Flag: Guyana" & @CRLF & _
" ๐ญ๐ฐ Flag: Hong Kong SAR China" & @CRLF & _
" ๐ญ๐ฒ Flag: Heard & McDonald Islands" & @CRLF & _
" ๐ญ๐ณ Flag: Honduras" & @CRLF & _
" ๐ญ๐ท Flag: Croatia" & @CRLF & _
" ๐ญ๐น Flag: Haiti" & @CRLF & _
" ๐ญ๐บ Flag: Hungary" & @CRLF & _
" ๐ฎ๐จ Flag: Canary Islands" & @CRLF & _
" ๐ฎ๐ฉ Flag: Indonesia" & @CRLF & _
" ๐ฎ๐ช Flag: Ireland" & @CRLF & _
" ๐ฎ๐ฑ Flag: Israel" & @CRLF & _
" ๐ฎ๐ฒ Flag: Isle of Man" & @CRLF & _
" ๐ฎ๐ณ Flag: India" & @CRLF & _
" ๐ฎ๐ด Flag: British Indian Ocean Territory" & @CRLF & _
" ๐ฎ๐ถ Flag: Iraq" & @CRLF & _
" ๐ฎ๐ท Flag: Iran" & @CRLF & _
" ๐ฎ๐ธ Flag: Iceland" & @CRLF & _
" ๐ฎ๐น Flag: Italy" & @CRLF & _
" ๐ฏ๐ช Flag: Jersey" & @CRLF & _
" ๐ฏ๐ฒ Flag: Jamaica" & @CRLF & _
" ๐ฏ๐ด Flag: Jordan" & @CRLF & _
" ๐ฏ๐ต Flag: Japan" & @CRLF & _
" ๐ฐ๐ช Flag: Kenya" & @CRLF & _
" ๐ฐ๐ฌ Flag: Kyrgyzstan" & @CRLF & _
" ๐ฐ๐ญ Flag: Cambodia" & @CRLF & _
" ๐ฐ๐ฎ Flag: Kiribati" & @CRLF & _
" ๐ฐ๐ฒ Flag: Comoros" & @CRLF & _
" ๐ฐ๐ณ Flag: St. Kitts & Nevis" & @CRLF & _
" ๐ฐ๐ต Flag: North Korea" & @CRLF & _
" ๐ฐ๐ท Flag: South Korea" & @CRLF & _
" ๐ฐ๐ผ Flag: Kuwait" & @CRLF & _
" ๐ฐ๐พ Flag: Cayman Islands" & @CRLF & _
" ๐ฐ๐ฟ Flag: Kazakhstan" & @CRLF & _
" ๐ฑ๐ฆ Flag: Laos" & @CRLF & _
" ๐ฑ๐ง Flag: Lebanon" & @CRLF & _
" ๐ฑ๐จ Flag: St. Lucia" & @CRLF & _
" ๐ฑ๐ฎ Flag: Liechtenstein" & @CRLF & _
" ๐ฑ๐ฐ Flag: Sri Lanka" & @CRLF & _
" ๐ฑ๐ท Flag: Liberia" & @CRLF & _
" ๐ฑ๐ธ Flag: Lesotho" & @CRLF & _
" ๐ฑ๐น Flag: Lithuania" & @CRLF & _
" ๐ฑ๐บ Flag: Luxembourg" & @CRLF & _
" ๐ฑ๐ป Flag: Latvia" & @CRLF & _
" ๐ฑ๐พ Flag: Libya" & @CRLF & _
" ๐ฒ๐ฆ Flag: Morocco" & @CRLF & _
" ๐ฒ๐จ Flag: Monaco" & @CRLF & _
" ๐ฒ๐ฉ Flag: Moldova" & @CRLF & _
" ๐ฒ๐ช Flag: Montenegro" & @CRLF & _
" ๐ฒ๐ซ Flag: St. Martin" & @CRLF & _
" ๐ฒ๐ฌ Flag: Madagascar" & @CRLF & _
" ๐ฒ๐ญ Flag: Marshall Islands" & @CRLF & _
" ๐ฒ๐ฐ Flag: North Macedonia" & @CRLF & _
" ๐ฒ๐ฑ Flag: Mali" & @CRLF & _
" ๐ฒ๐ฒ Flag: Myanmar (Burma)" & @CRLF & _
" ๐ฒ๐ณ Flag: Mongolia" & @CRLF & _
" ๐ฒ๐ด Flag: Macau Sar China" & @CRLF & _
" ๐ฒ๐ต Flag: Northern Mariana Islands" & @CRLF & _
" ๐ฒ๐ถ Flag: Martinique" & @CRLF & _
" ๐ฒ๐ท Flag: Mauritania" & @CRLF & _
" ๐ฒ๐ธ Flag: Montserrat" & @CRLF & _
" ๐ฒ๐น Flag: Malta" & @CRLF & _
" ๐ฒ๐บ Flag: Mauritius" & @CRLF & _
" ๐ฒ๐ป Flag: Maldives" & @CRLF & _
" ๐ฒ๐ผ Flag: Malawi" & @CRLF & _
" ๐ฒ๐ฝ Flag: Mexico" & @CRLF & _
" ๐ฒ๐พ Flag: Malaysia" & @CRLF & _
" ๐ฒ๐ฟ Flag: Mozambique" & @CRLF & _
" ๐ณ๐ฆ Flag: Namibia" & @CRLF & _
" ๐ณ๐จ Flag: New Caledonia" & @CRLF & _
" ๐ณ๐ช Flag: Niger" & @CRLF & _
" ๐ณ๐ซ Flag: Norfolk Island" & @CRLF & _
" ๐ณ๐ฌ Flag: Nigeria" & @CRLF & _
" ๐ณ๐ฎ Flag: Nicaragua" & @CRLF & _
" ๐ณ๐ฑ Flag: Netherlands" & @CRLF & _
" ๐ณ๐ด Flag: Norway" & @CRLF & _
" ๐ณ๐ต Flag: Nepal" & @CRLF & _
" ๐ณ๐ท Flag: Nauru" & @CRLF & _
" ๐ณ๐บ Flag: Niue" & @CRLF & _
" ๐ณ๐ฟ Flag: New Zealand" & @CRLF & _
" ๐ด๐ฒ Flag: Oman" & @CRLF & _
" ๐ต๐ฆ Flag: Panama" & @CRLF & _
" ๐ต๐ช Flag: Peru" & @CRLF & _
" ๐ต๐ซ Flag: French Polynesia" & @CRLF & _
" ๐ต๐ฌ Flag: Papua New Guinea" & @CRLF & _
" ๐ต๐ญ Flag: Philippines" & @CRLF & _
" ๐ต๐ฐ Flag: Pakistan" & @CRLF & _
" ๐ต๐ฑ Flag: Poland" & @CRLF & _
" ๐ต๐ฒ Flag: St. Pierre & Miquelon" & @CRLF & _
" ๐ต๐ณ Flag: Pitcairn Islands" & @CRLF & _
" ๐ต๐ท Flag: Puerto Rico" & @CRLF & _
" ๐ต๐ธ Flag: Palestinian Territories" & @CRLF & _
" ๐ต๐น Flag: Portugal" & @CRLF & _
" ๐ต๐ผ Flag: Palau" & @CRLF & _
" ๐ต๐พ Flag: Paraguay" & @CRLF & _
" ๐ถ๐ฆ Flag: Qatar" & @CRLF & _
" ๐ท๐ช Flag: Rรฉunion" & @CRLF & _
" ๐ท๐ด Flag: Romania" & @CRLF & _
" ๐ท๐ธ Flag: Serbia" & @CRLF & _
" ๐ท๐บ Flag: Russia" & @CRLF & _
" ๐ท๐ผ Flag: Rwanda" & @CRLF & _
" ๐ธ๐ฆ Flag: Saudi Arabia" & @CRLF & _
" ๐ธ๐ง Flag: Solomon Islands" & @CRLF & _
" ๐ธ๐จ Flag: Seychelles" & @CRLF & _
" ๐ธ๐ฉ Flag: Sudan" & @CRLF & _
" ๐ธ๐ช Flag: Sweden" & @CRLF & _
" ๐ธ๐ฌ Flag: Singapore" & @CRLF & _
" ๐ธ๐ญ Flag: St. Helena" & @CRLF & _
" ๐ธ๐ฎ Flag: Slovenia" & @CRLF & _
" ๐ธ๐ฏ Flag: Svalbard & Jan Mayen" & @CRLF & _
" ๐ธ๐ฐ Flag: Slovakia" & @CRLF & _
" ๐ธ๐ฑ Flag: Sierra Leone" & @CRLF & _
" ๐ธ๐ฒ Flag: San Marino" & @CRLF & _
" ๐ธ๐ณ Flag: Senegal" & @CRLF & _
" ๐ธ๐ด Flag: Somalia" & @CRLF & _
" ๐ธ๐ท Flag: Suriname" & @CRLF & _
" ๐ธ๐ธ Flag: South Sudan" & @CRLF & _
" ๐ธ๐น Flag: Sรฃo Tomรฉ & Prรญncipe" & @CRLF & _
" ๐ธ๐ป Flag: El Salvador" & @CRLF & _
" ๐ธ๐ฝ Flag: Sint Maarten" & @CRLF & _
" ๐ธ๐พ Flag: Syria" & @CRLF & _
" ๐ธ๐ฟ Flag: Swaziland" & @CRLF & _
" ๐น๐ฆ Flag: Tristan Da Cunha" & @CRLF & _
" ๐น๐จ Flag: Turks & Caicos Islands" & @CRLF & _
" ๐น๐ฉ Flag: Chad" & @CRLF & _
" ๐น๐ซ Flag: French Southern Territories" & @CRLF & _
" ๐น๐ฌ Flag: Togo" & @CRLF & _
" ๐น๐ญ Flag: Thailand" & @CRLF & _
" ๐น๐ฏ Flag: Tajikistan" & @CRLF & _
" ๐น๐ฐ Flag: Tokelau" & @CRLF & _
" ๐น๐ฑ Flag: Timor-Leste" & @CRLF & _
" ๐น๐ฒ Flag: Turkmenistan" & @CRLF & _
" ๐น๐ณ Flag: Tunisia" & @CRLF & _
" ๐น๐ด Flag: Tonga" & @CRLF & _
" ๐น๐ท Flag: Turkey" & @CRLF & _
" ๐น๐น Flag: Trinidad & Tobago" & @CRLF & _
" ๐น๐ป Flag: Tuvalu" & @CRLF & _
" ๐น๐ผ Flag: Taiwan" & @CRLF & _
" ๐น๐ฟ Flag: Tanzania" & @CRLF & _
" ๐บ๐ฆ Flag: Ukraine" & @CRLF & _
" ๐บ๐ฌ Flag: Uganda" & @CRLF & _
" ๐บ๐ฒ Flag: U.S. Outlying Islands" & @CRLF & _
" ๐บ๐ณ Flag: United Nations" & @CRLF & _
" ๐บ๐ธ Flag: United States" & @CRLF & _
" ๐บ๐พ Flag: Uruguay" & @CRLF & _
" ๐บ๐ฟ Flag: Uzbekistan" & @CRLF & _
" ๐ป๐ฆ Flag: Vatican City" & @CRLF & _
" ๐ป๐จ Flag: St. Vincent & Grenadines" & @CRLF & _
" ๐ป๐ช Flag: Venezuela" & @CRLF & _
" ๐ป๐ฌ Flag: British Virgin Islands" & @CRLF & _
" ๐ป๐ฎ Flag: U.S. Virgin Islands" & @CRLF & _
" ๐ป๐ณ Flag: Vietnam" & @CRLF & _
" ๐ป๐บ Flag: Vanuatu" & @CRLF & _
" ๐ผ๐ซ Flag: Wallis & Futuna" & @CRLF & _
" ๐ผ๐ธ Flag: Samoa" & @CRLF & _
" ๐ฝ๐ฐ Flag: Kosovo" & @CRLF & _
" ๐พ๐ช Flag: Yemen" & @CRLF & _
" ๐พ๐น Flag: Mayotte" & @CRLF & _
" ๐ฟ๐ฆ Flag: South Africa" & @CRLF & _
" ๐ฟ๐ฒ Flag: Zambia" & @CRLF & _
" ๐ฟ๐ผ Flag: Zimbabwe" & @CRLF & _
" ๐ด๓ ง๓ ข๓ ฅ๓ ฎ๓ ง๓ ฟ Flag: England" & @CRLF & _
" ๐ด๓ ง๓ ข๓ ณ๓ ฃ๓ ด๓ ฟ Flag: Scotland" & @CRLF & _
" ๐ด๓ ง๓ ข๓ ท๓ ฌ๓ ณ๓ ฟ Flag: Wales" & @CRLF & _
" ๐ณ๏ธโโง๏ธ Transgender Flag" & @CRLF & _
" ๐ด๓ ต๓ ณ๓ ด๓ ธ๓ ฟ Flag for Texas (US-TX)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")