// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\x{1F1E6}-\x{1F1FF}]{2}|๐ด[\x{E0041}-\x{E007A}]{4,5}\x{E007F}").unwrap();
let string = "
๐ Chequered Flag
๐ฉ Triangular Flag
๐ Crossed Flags
๐ด Black Flag
๐ณ White Flag
๐ณ๏ธโ๐ Rainbow Flag
๐ดโโ ๏ธ Pirate Flag
๐ฆ๐จ Flag: Ascension Island
๐ฆ๐ฉ Flag: Andorra
๐ฆ๐ช Flag: United Arab Emirates
๐ฆ๐ซ Flag: Afghanistan
๐ฆ๐ฌ Flag: Antigua & Barbuda
๐ฆ๐ฎ Flag: Anguilla
๐ฆ๐ฑ Flag: Albania
๐ฆ๐ฒ Flag: Armenia
๐ฆ๐ด Flag: Angola
๐ฆ๐ถ Flag: Antarctica
๐ฆ๐ท Flag: Argentina
๐ฆ๐ธ Flag: American Samoa
๐ฆ๐น Flag: Austria
๐ฆ๐บ Flag: Australia
๐ฆ๐ผ Flag: Aruba
๐ฆ๐ฝ Flag: ร
land Islands
๐ฆ๐ฟ Flag: Azerbaijan
๐ง๐ฆ Flag: Bosnia & Herzegovina
๐ง๐ง Flag: Barbados
๐ง๐ฉ Flag: Bangladesh
๐ง๐ช Flag: Belgium
๐ง๐ซ Flag: Burkina Faso
๐ง๐ฌ Flag: Bulgaria
๐ง๐ญ Flag: Bahrain
๐ง๐ฎ Flag: Burundi
๐ง๐ฏ Flag: Benin
๐ง๐ฑ Flag: St. Barthรฉlemy
๐ง๐ฒ Flag: Bermuda
๐ง๐ณ Flag: Brunei
๐ง๐ด Flag: Bolivia
๐ง๐ถ Flag: Caribbean Netherlands
๐ง๐ท Flag: Brazil
๐ง๐ธ Flag: Bahamas
๐ง๐น Flag: Bhutan
๐ง๐ป Flag: Bouvet Island
๐ง๐ผ Flag: Botswana
๐ง๐พ Flag: Belarus
๐ง๐ฟ Flag: Belize
๐จ๐ฆ Flag: Canada
๐จ๐จ Flag: Cocos (Keeling) Islands
๐จ๐ฉ Flag: Congo - Kinshasa
๐จ๐ซ Flag: Central African Republic
๐จ๐ฌ Flag: Congo - Brazzaville
๐จ๐ญ Flag: Switzerland
๐จ๐ฎ Flag: Cรดte dโIvoire
๐จ๐ฐ Flag: Cook Islands
๐จ๐ฑ Flag: Chile
๐จ๐ฒ Flag: Cameroon
๐จ๐ณ Flag: China
๐จ๐ด Flag: Colombia
๐จ๐ต Flag: Clipperton Island
๐จ๐ท Flag: Costa Rica
๐จ๐บ Flag: Cuba
๐จ๐ป Flag: Cape Verde
๐จ๐ผ Flag: Curaรงao
๐จ๐ฝ Flag: Christmas Island
๐จ๐พ Flag: Cyprus
๐จ๐ฟ Flag: Czechia
๐ฉ๐ช Flag: Germany
๐ฉ๐ฌ Flag: Diego Garcia
๐ฉ๐ฏ Flag: Djibouti
๐ฉ๐ฐ Flag: Denmark
๐ฉ๐ฒ Flag: Dominica
๐ฉ๐ด Flag: Dominican Republic
๐ฉ๐ฟ Flag: Algeria
๐ช๐ฆ Flag: Ceuta & Melilla
๐ช๐จ Flag: Ecuador
๐ช๐ช Flag: Estonia
๐ช๐ฌ Flag: Egypt
๐ช๐ญ Flag: Western Sahara
๐ช๐ท Flag: Eritrea
๐ช๐ธ Flag: Spain
๐ช๐น Flag: Ethiopia
๐ช๐บ Flag: European Union
๐ซ๐ฎ Flag: Finland
๐ซ๐ฏ Flag: Fiji
๐ซ๐ฐ Flag: Falkland Islands
๐ซ๐ฒ Flag: Micronesia
๐ซ๐ด Flag: Faroe Islands
๐ซ๐ท Flag: France
๐ฌ๐ฆ Flag: Gabon
๐ฌ๐ง Flag: United Kingdom
๐ฌ๐ฉ Flag: Grenada
๐ฌ๐ช Flag: Georgia
๐ฌ๐ซ Flag: French Guiana
๐ฌ๐ฌ Flag: Guernsey
๐ฌ๐ญ Flag: Ghana
๐ฌ๐ฎ Flag: Gibraltar
๐ฌ๐ฑ Flag: Greenland
๐ฌ๐ฒ Flag: Gambia
๐ฌ๐ณ Flag: Guinea
๐ฌ๐ต Flag: Guadeloupe
๐ฌ๐ถ Flag: Equatorial Guinea
๐ฌ๐ท Flag: Greece
๐ฌ๐ธ Flag: South Georgia & South Sandwich Islands
๐ฌ๐น Flag: Guatemala
๐ฌ๐บ Flag: Guam
๐ฌ๐ผ Flag: Guinea-Bissau
๐ฌ๐พ Flag: Guyana
๐ญ๐ฐ Flag: Hong Kong SAR China
๐ญ๐ฒ Flag: Heard & McDonald Islands
๐ญ๐ณ Flag: Honduras
๐ญ๐ท Flag: Croatia
๐ญ๐น Flag: Haiti
๐ญ๐บ Flag: Hungary
๐ฎ๐จ Flag: Canary Islands
๐ฎ๐ฉ Flag: Indonesia
๐ฎ๐ช Flag: Ireland
๐ฎ๐ฑ Flag: Israel
๐ฎ๐ฒ Flag: Isle of Man
๐ฎ๐ณ Flag: India
๐ฎ๐ด Flag: British Indian Ocean Territory
๐ฎ๐ถ Flag: Iraq
๐ฎ๐ท Flag: Iran
๐ฎ๐ธ Flag: Iceland
๐ฎ๐น Flag: Italy
๐ฏ๐ช Flag: Jersey
๐ฏ๐ฒ Flag: Jamaica
๐ฏ๐ด Flag: Jordan
๐ฏ๐ต Flag: Japan
๐ฐ๐ช Flag: Kenya
๐ฐ๐ฌ Flag: Kyrgyzstan
๐ฐ๐ญ Flag: Cambodia
๐ฐ๐ฎ Flag: Kiribati
๐ฐ๐ฒ Flag: Comoros
๐ฐ๐ณ Flag: St. Kitts & Nevis
๐ฐ๐ต Flag: North Korea
๐ฐ๐ท Flag: South Korea
๐ฐ๐ผ Flag: Kuwait
๐ฐ๐พ Flag: Cayman Islands
๐ฐ๐ฟ Flag: Kazakhstan
๐ฑ๐ฆ Flag: Laos
๐ฑ๐ง Flag: Lebanon
๐ฑ๐จ Flag: St. Lucia
๐ฑ๐ฎ Flag: Liechtenstein
๐ฑ๐ฐ Flag: Sri Lanka
๐ฑ๐ท Flag: Liberia
๐ฑ๐ธ Flag: Lesotho
๐ฑ๐น Flag: Lithuania
๐ฑ๐บ Flag: Luxembourg
๐ฑ๐ป Flag: Latvia
๐ฑ๐พ Flag: Libya
๐ฒ๐ฆ Flag: Morocco
๐ฒ๐จ Flag: Monaco
๐ฒ๐ฉ Flag: Moldova
๐ฒ๐ช Flag: Montenegro
๐ฒ๐ซ Flag: St. Martin
๐ฒ๐ฌ Flag: Madagascar
๐ฒ๐ญ Flag: Marshall Islands
๐ฒ๐ฐ Flag: North Macedonia
๐ฒ๐ฑ Flag: Mali
๐ฒ๐ฒ Flag: Myanmar (Burma)
๐ฒ๐ณ Flag: Mongolia
๐ฒ๐ด Flag: Macau Sar China
๐ฒ๐ต Flag: Northern Mariana Islands
๐ฒ๐ถ Flag: Martinique
๐ฒ๐ท Flag: Mauritania
๐ฒ๐ธ Flag: Montserrat
๐ฒ๐น Flag: Malta
๐ฒ๐บ Flag: Mauritius
๐ฒ๐ป Flag: Maldives
๐ฒ๐ผ Flag: Malawi
๐ฒ๐ฝ Flag: Mexico
๐ฒ๐พ Flag: Malaysia
๐ฒ๐ฟ Flag: Mozambique
๐ณ๐ฆ Flag: Namibia
๐ณ๐จ Flag: New Caledonia
๐ณ๐ช Flag: Niger
๐ณ๐ซ Flag: Norfolk Island
๐ณ๐ฌ Flag: Nigeria
๐ณ๐ฎ Flag: Nicaragua
๐ณ๐ฑ Flag: Netherlands
๐ณ๐ด Flag: Norway
๐ณ๐ต Flag: Nepal
๐ณ๐ท Flag: Nauru
๐ณ๐บ Flag: Niue
๐ณ๐ฟ Flag: New Zealand
๐ด๐ฒ Flag: Oman
๐ต๐ฆ Flag: Panama
๐ต๐ช Flag: Peru
๐ต๐ซ Flag: French Polynesia
๐ต๐ฌ Flag: Papua New Guinea
๐ต๐ญ Flag: Philippines
๐ต๐ฐ Flag: Pakistan
๐ต๐ฑ Flag: Poland
๐ต๐ฒ Flag: St. Pierre & Miquelon
๐ต๐ณ Flag: Pitcairn Islands
๐ต๐ท Flag: Puerto Rico
๐ต๐ธ Flag: Palestinian Territories
๐ต๐น Flag: Portugal
๐ต๐ผ Flag: Palau
๐ต๐พ Flag: Paraguay
๐ถ๐ฆ Flag: Qatar
๐ท๐ช Flag: Rรฉunion
๐ท๐ด Flag: Romania
๐ท๐ธ Flag: Serbia
๐ท๐บ Flag: Russia
๐ท๐ผ Flag: Rwanda
๐ธ๐ฆ Flag: Saudi Arabia
๐ธ๐ง Flag: Solomon Islands
๐ธ๐จ Flag: Seychelles
๐ธ๐ฉ Flag: Sudan
๐ธ๐ช Flag: Sweden
๐ธ๐ฌ Flag: Singapore
๐ธ๐ญ Flag: St. Helena
๐ธ๐ฎ Flag: Slovenia
๐ธ๐ฏ Flag: Svalbard & Jan Mayen
๐ธ๐ฐ Flag: Slovakia
๐ธ๐ฑ Flag: Sierra Leone
๐ธ๐ฒ Flag: San Marino
๐ธ๐ณ Flag: Senegal
๐ธ๐ด Flag: Somalia
๐ธ๐ท Flag: Suriname
๐ธ๐ธ Flag: South Sudan
๐ธ๐น Flag: Sรฃo Tomรฉ & Prรญncipe
๐ธ๐ป Flag: El Salvador
๐ธ๐ฝ Flag: Sint Maarten
๐ธ๐พ Flag: Syria
๐ธ๐ฟ Flag: Swaziland
๐น๐ฆ Flag: Tristan Da Cunha
๐น๐จ Flag: Turks & Caicos Islands
๐น๐ฉ Flag: Chad
๐น๐ซ Flag: French Southern Territories
๐น๐ฌ Flag: Togo
๐น๐ญ Flag: Thailand
๐น๐ฏ Flag: Tajikistan
๐น๐ฐ Flag: Tokelau
๐น๐ฑ Flag: Timor-Leste
๐น๐ฒ Flag: Turkmenistan
๐น๐ณ Flag: Tunisia
๐น๐ด Flag: Tonga
๐น๐ท Flag: Turkey
๐น๐น Flag: Trinidad & Tobago
๐น๐ป Flag: Tuvalu
๐น๐ผ Flag: Taiwan
๐น๐ฟ Flag: Tanzania
๐บ๐ฆ Flag: Ukraine
๐บ๐ฌ Flag: Uganda
๐บ๐ฒ Flag: U.S. Outlying Islands
๐บ๐ณ Flag: United Nations
๐บ๐ธ Flag: United States
๐บ๐พ Flag: Uruguay
๐บ๐ฟ Flag: Uzbekistan
๐ป๐ฆ Flag: Vatican City
๐ป๐จ Flag: St. Vincent & Grenadines
๐ป๐ช Flag: Venezuela
๐ป๐ฌ Flag: British Virgin Islands
๐ป๐ฎ Flag: U.S. Virgin Islands
๐ป๐ณ Flag: Vietnam
๐ป๐บ Flag: Vanuatu
๐ผ๐ซ Flag: Wallis & Futuna
๐ผ๐ธ Flag: Samoa
๐ฝ๐ฐ Flag: Kosovo
๐พ๐ช Flag: Yemen
๐พ๐น Flag: Mayotte
๐ฟ๐ฆ Flag: South Africa
๐ฟ๐ฒ Flag: Zambia
๐ฟ๐ผ Flag: Zimbabwe
๐ด๓ ง๓ ข๓ ฅ๓ ฎ๓ ง๓ ฟ Flag: England
๐ด๓ ง๓ ข๓ ณ๓ ฃ๓ ด๓ ฟ Flag: Scotland
๐ด๓ ง๓ ข๓ ท๓ ฌ๓ ณ๓ ฟ Flag: Wales
๐ณ๏ธโโง๏ธ Transgender Flag
๐ด๓ ต๓ ณ๓ ด๓ ธ๓ ฟ Flag for Texas (US-TX)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}