using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&(?![a-z]*;)";
string input = @"<p> </p>
<p>This & That</p>
<p> </p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}