$re = '/&(?![a-z]*;)/m';
$str = '<p> </p>
<p>This & That</p>
<p> </p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);