package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\AVS-order-export-\d+\.xml\z`)
var str = `VS-order-export-105.xml`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}