$re = '/\AVS-order-export-\d+\.xml\z/';
$str = 'VS-order-export-105.xml';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);