const regex = /(?<=The SID is )\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=The SID is )\\S+', 'gm')
const str = `The SID is S-1-9-1551374245-3853148685-361627209-2951783729-4075502353-0-0-0-0-3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}