$re = '/(?<=The SID is )\S+/m';
$str = 'The SID is S-1-9-1551374245-3853148685-361627209-2951783729-4075502353-0-0-0-0-3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);