const regex = /(?<=^[^\S\n\v\f\r\u2028\u2029]*)[^\S\n\v\f\r\u2028\u2029]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^[^\\S\\n\\v\\f\\r\\u2028\\u2029]*)[^\\S\\n\\v\\f\\r\\u2028\\u2029]', 'gm')
const str = ` Some text here
Some new line text here`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);