re = /(?<=^[^\S\n\v\f\r\u2028\u2029]*)[^\S\n\v\f\r\u2028\u2029]/m
str = ' Some text here
Some new line text here'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result