package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/home/user/([^/]+)`)
var str = `/home/user
/home/user/
/home/user/foo
/home/user/bar/foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}